Download

Android Anti Aliasing? - WTF?

Hello together,

so… I’m investigating Mobile AA since a few days (Android 7 / Galaxy S7). I’m not able to have any AA working that is effecting mobile. Turning it Off or On has the same results.
Frist I thought it’s a GearVR related problem. But now I see it’s also not working in a standard mobile version on a Galaxy S7.

I was reading around 100 different threads here and on answerhub. Everyone is bringing some tips what I should change in different INI files or even changing the source code of the engine.
Since changing .ini files didn’t have any effect I guess building the engine with changed source code doesn’t make sense at all?

How can it be that there is no “how the !#!§ is AA on mobile working” documentation.

Pretty angry right now. I love unreal but I’m at the point where I consider switching to unity for this project.

Can anyone give me a hint what I have to do to get the maximum AA on mobile that is available in Unreal up and running?

Go into your device profiles… It might look daunting at first, but please try to give it time to sink in…

I’m still new to unreal and Android development, so I took the time to research what console variables (CVars) I would ever need to modify

What I did first was create a new device profile that parents “Android”, I would then add in all of the CVars I listed before (but not modify them)
Next thing, I would do is find out what Device Profile your android device runs, to find this out I just print a string off of a Event BeginPlay somewhere in my game logic https://i.gyazo.com/35c132672d47789f5e921fddd5536cab.png
Find your device in the profiles list, in my case it was “Android_Mali_T7xx” https://i.gyazo.com/e403b64bb66b74e91bc7fdea38b5e616.png
You only need to edit the CVars within Rendering (r.####), and Scalability Group (sg.####) https://i.gyazo.com/29cfad187ef1d792c5f623bfc2c36cb7.png

If I had to guess, you might be looking specifically for the CVar “sg.AntiAliasingQuality”, “sg.AntiAliasingQuality.NumLevels”, “r.PostProcessingAAQuality”, also your “r.MobileContentScaleFactor”, and “sg.ResolutionQuality” will play a roll in how much Aliasing you’re seeing

If you need to know what each CVar does, I happened upon this awesome site (old’ish) where someone dumped the CVars and their comments UE4 Console Variables and Commands really awesome resource

Edit: Before I forget, here are a list of the CVars I’m currently using (idk how of these are actually effecting the final cooked build, but the majority of these I think are interacting with performance and visuals CVar Value Help/Notes-MAIN-r.MobileContentScaleFactor 0-3 r.Set - Pastebin.com just copy and paste it into note pad and it will look all ncie and tidy https://i.gyazo.com/dfdb8d7aa2ee09276f7601842b9b83ee.png

Your DefaultDeviceProfiles.ini can be found “C:\Users#USER\Documents\Unreal Projects#ProjectName\Config”

Hey, thank you so much for the reply. I think this should be pinned somewhere so it also can help other users in the future.
Got the AA it self working (also with the defaultdeviceprofiles.ini) in the meanwhile.

But since this is fixed, we saw that the videoquality on android is pretty bad. the video looks jagged / edgy / jittery, as if it would be rendered at half resolution. doesn’t seem to be related to AA
We have a 4k video playing on a sphere. looks really bad in unreal - looks perfect in unity.

any idea about that? :slight_smile:

Hmm… Check to see that “r.MobileContentScaleFactor” correctly set, factor of 2 gives you 2560 x 1440 for Landscape and 1440 x 2560 for portrait
“r.PostProcessAAQuality” (0-6)
“r.SetRes ##x##w/f” (w-Windowed | f-Full Screen |wf-Windowed Full Screen) Don’t believe this CVar effects Mobile builds
“sg.ResolutionQuality” (0-100)
“sg.AntiAliasingQuality” (0-3)

I’m still new to mobile development, and Unreal in general, but yes, I do agree completely that something like this should be pinned to forums :wink:

Sorry guys I have the same problem you were discussing so much time ago… I followed the instructions till custom CVar settings on my Adreno5xx (oculus go)… but still the antialiasing seems not to work at all! (is there something to do after changing the device profile?)

Can you please help me?

An other weird thing… I attach the screenshot taken on my oculus. Frankly speaking the picture is quite good… but I can assure you that the feeling when displayed on oculus is horrible… a lot of aliasing!!
the temple map… same behavior… the red circles are horrible once seen on oculus… while now on my PC they look not that bad

HI,have u solve your problem like this,I also have the problem on Pico

there are several ways to adjust mobile AA
first of all your screen resolution affects your AA tremendously, you can adjust your screen resolution with this command:
r.MobileContentScaleFactor (0 = native device resolution 1 = 1280x720 and anything between 0 and 1 will be less than 1280x720 which makes the screen pretty blurry)
secondly there are 2 types of commands for adjusting mobile AA
r.PostProcessAAQuality 0 to 3 (this command is quite effective on AA side but for a cleaner image use mobile msaa )
r.MobileMSAA
1: Use Temporal AA (MSAA disabled)
2: Use 2x MSAA (Temporal AA disabled)
4: Use 4x MSAA (Temporal AA disabled)
keep in mind that you have to enable mobile msaa support from project settings.

just in case you want sources here are the links:

http://www.kosmokleaner.de/ownsoft/UE4CVarBrowser.html

Hello, have someone fixed the android antialiasin question? Thankyou

hello i am not able to fix this issue can anyone help me out?

trying from past 10 days