Android 4.16 - device compatibility reduction?

Has anyone noticed a dip in device compatibility since updating to 4.16?

Getting what I would guess as GPU crashes on Lenovo A526 (A526), and Samsung Galaxy Tab 4 SM-T530NYKAXAR (this samsung has worked with the game for a long time)

I am going to do a recook with a clean Android Works installation and hope perhaps that was why this came up

“Input dispatching timed out (Waiting to send non-key event because the touched window has not finished processing ce” is the only ANR being reported - what should I make of that?

I wouldn’t expect it to stop working. Looks like it has an Adreno 305. Is there anything else in the logcat to go on? Which version of Android is installed?

The user who reported this on his samsung has been playing my game for a long time across many unreal versions, he was reporting this issue would reboot his device. I have a few other reports of this in my reviews

these are my top crashes on the same issue atm

Android 5.1 - LG K7 (m1)
Android 5.1 - MS45S (MS45S)
Android 6.0 - Moto X (2nd Gen) (victara)

  • I tried building on a fresh codeworks install and lowered my min versions to 9 - perhaps that might resolve it, i just published so i dont have any data yet.
  • Also my dedicated servers are having trouble starting, they seem the crash out if the map takes too long to load, I see there is currently a fix for this happening in the editor coming for 4.16.1, perhaps its related? (.com/EpicGames/UnrealEngine/commit/3e128c7c35e06bc38b42e90a676e182bf5e0ae15)

see 4.16 - Dedicated Servers crashing - LinkerLoad.cpp - Programming & Scripting - Epic Developer Community Forums

also these are ANR reports sorry not crashes

so I’ve been getting reports of crashes, I have never been able to replicate them on my Shield Tablet, Samsung 5 or Google Pixel

I was having troubles with my dedicated servers and suggested I uncheck “Event Driven Loader Enabled” and that fixed the issue - anyway, I tried that for my mobile build - this is the first time I’ve been able to experience what my users have been reporting

So my question is, What settings should I put for a large game (100meg pak)? It seems to be slower devices fail out trying to load up my package

So if I disabled Event Driven Loader Enabled - then my game doesn’t load correctly at all. My menu will load with my umg screens that are enabled/disabled via logic all showing with no content loaded in them.

I tried enabling Async Loading and my one user with the Samsung Galaxy Tab 4 SM-T530NYKAXAR reported the game works.

could really use some guidance on this one :frowning: I’ve got 2,600 1 star reviews, I’m sure 1/3rd to 2/3rds of those are because the game didn’t load

I tried enabling async and boosting some of the numbers - it didn’t seem to help with the issue, not to mention when I played a multiplayer game of my game it broke behavior as well.


We’re currently looking into this issue. Could you get any of your users who are experiencing this crash to provide logs? Can you also provide logs for when the game doesn’t load correctly after disabling the Event Driven Loader?

For future reports like this, it is usually best to post something such as this on Answerhub in our Bug Reports section, but we can just handle correspondence for this issue here for now.

One thing I’ve been told about is to try using the commandline argument -RandomizeLoadOrder

This is not intended to be a fix as it actually slows down loading but it may be able to help you reproduce the issue itself and get log files of your own.

While packaging for es2.0 android device, output log shows error in landscape material compilation. What to do? I am using ue4 4.15.3

You can see the log file where it says “Cannot access field LayerWeights of structure”. How to resolve even when mobile texture samplers show only 3 ?? Please help… I have been stuck on it for days.

@Energitium perhaps create a new post on this issue

for my issue, I discovered it was my nav mesh working way too hard for no reason during map load which caused my above issues

thanks Epic staff for your help - sorry for not following up here, I did read your posts but I was so focused on solving the issue, then I was off to other fires