Android 4.1.2 app crashes on startup: "Unfortunately, kittystory has stopped"

After a week of trying for 4 hours a day, I finally got the magic combination of options and installation procedures to make a simple UMG + blueprints project (no level geometry or anything else) to package and install to my Samsung Galaxy S2 smartphone.However, the app crashes on startup with the popup alert “Unfortunately, kittystory has stopped.”

After reading probably every forum thread on the subject, I have run out of options.
I have attached my package launcher log and my android monitor log.

The only clue I can think of to follow might be that pesky OVR library .so file. I disabled almost every plugin, and made sure anything to do with Oculus was disabled. I tried packaging without editor content, starting out by the book with a fresh package, installing additional SDKs via SDK manager.

Because the Android version is 4.1.2 (building from Unreal 4.17.1 or 4.17.2) that seems to put the API version around android-16, so I set that to be my NDK in the project settings, and set my minimum and target versions to be 16 too, so they all should match.

I suspect this line in the monitor log.txt is the culprit, but I removed everything related to Oculus VR, and I don’t know how to get it to stop requiring it: java.lang.UnsatisfiedLinkError: Cannot load library: link_image[1891]: 164 could not load needed library ‘’ for ‘’ (find_library[1201]: 164 ‘’ failed to load previously)[link text][1]

You will see in the screenshot that once the app launches and soon afterward crashes, the launcher gets stuck on the “Waiting for server…” part forever. I will try again tomorrow to get the monitor log.txt to you, as I think that might be the key.

In another forum post, someone was told to update their firmware to solve problems related to that OVR file. I can’t do this because my when I tap my phon’es Software Update in the Settings, it pops up a little message saying “No firmware”.

I am new to Android in every way. Is it this hard for everyone else? Or is my phone just special?
Samsung model SGH-T989
Android Version 4.1.2
Baseband version T989UVMC6
Kernel Version 3.0.31-1003885
se.infra@SEP131 #1
SMP PREEMPT Mon Mar 11 18:32:51
KST 2013

Build Number JZ054k.T989UVMC6

I just corrected the version number in the title. Plus, today I updated from 4.17.1 to 4.17.2, and tried created a brand new, blank mobile scaleable project. This did not fix the issue.

Even if I disable all VR-related plugins, save my project, quit the Editor, then restart the Editor by loading my new project from the library, and confirm that Oculus is not in the Project Settings anywhere anymore, it still on the first build will include a bunch of Oculus-related third party library SO files, which upon trying to launch the app, will immediately crash due to those libraries not actually existing (it was doing this before I tried removing the plugins. It makes no difference).

on another forum, someone suggested I remove any references to Oculus in my .uproject file, but that made no difference in the packaging or installing or launching behavior. It’s still totally sure I want a non-working Oculus library named in my deployment of the app to my Samsung Galaxy S2 phone.

How do I get rid of this Oculus thing? I think my my would actually start on the phone if it didn’t keep trying to include it.

That device had insufficient RAM to run the engine. Using a better device solved the problem.