Download

Android 10 Save Game Doesn't Work

Hello, I have a published game on google play store, which already sold more than 500 and already has active players with save files. When I am publishing, I did not check the Use ExternalFilesDir option. Because for most of the devices save and load function works. But as I get from the reviews and comments under the game, most of the Android 10 users cannot save the game. If I check Use ExternalFilesDir option and update the game, I know all users who have already played the game will loose their save data. We do not want that because most of them already bought in app purchases and in game currency. Is there any way for us to fix this save game issue for android 10 without loosing the active players save data?

Note, I ask for write external permission on start. I checked on my Android 10 device for the application permissions and it has writing permission already. But still doesn’t save.

I tried the game on Android 10, in folder manager, UE4Game folder is not event created while playing, so it’s not writing.

Thanks in advance.

Fixed by changing target api from 29 to 28.

But API 28 is Android 9.

Having the same issue, we can’t just set it to use External Directory, because previous users will lose their saves. Is there a potential solution? Engine fix or CL for this?

We need the saves to remain in the games internal directory / files / UE4/Saved/Savegames folder.

Do you recommend we just pull the internal saves if they exist?