Download

an issue for linux users (about the mono-gmcs package) and a solution

hello everyone , I’m here to point out a problem encountered by I think many linux users (ubuntu 14.04 for me) trying to compile from sources UE4 and I couldn’t find any solution for it anywhere so I’m here to post mine and maybe to help .

In the installation guide , on the prerequisite part , it is told to do the following :



sudo apt-get install build-essential mono-gmcs mono-xbuild mono-dmcs libmono-corlib4.0-cil libmono-system-data-datasetextensions4.0-cil 
libmono-system-web-extensions4.0-cil libmono-system-management4.0-cil libmono-system-xml-linq4.0-cil cmake dos2unix clang-3.5 libfreetype6-dev libgtk-3-dev libmono-microsoft-build-tasks-v4.0-4.0-cil xdg-user-dirs

but then this error come for some of us :


The following packages have unmet dependencies: mono-gmcs : Depends: mono-mcs (= 3.12.1-0xamarin1) but 4.0.2.5-0xamarin1 is to be installed E: Unable to correct problems, you have held broken packages.

I figured an easy way to overcome this , first do your apt-get install without mono-gmcs, then do :


sudo aptitude install mono-gmcs


aptitude will propose you a first solution wich is to keep everything like it is , do not accept that solution by entering n .

then it will propose you another solution wich will downgrade some packages to anterior versions compatible with mono-gmcs . Accept by entering Y (or y I don’t remember) .

It worked for me , I hope if you have the same problem than me it will work for you . If this solution is approved , I think the mono-gmcs issue should be added to the known issues installation and set up guide , because while

I was searching for a solution I’ve seen many people in the same case who couldn’t get an answer .