AMD r9 380 very frequent crashes


after reading and commenting in the following thread:

i have been asked to create a new question if thing did not work out.

I have an AMD r9 380 video card since mid july.
the first driver for the video card were not even part of catalyst package, so with “beta” driver, i was not surprised to have very frequent video driver crash while using unreal. [ the system survives the crash ].
it was on windows 7.

now i’m on windows 10, with drivers part of catalyst package, and it still crashes the same way:
as soon as i start doing anything in the 3d viewport, i’m lucky to last 30 seconds of simply moving around with right click and WASD.

1st thing i tried is the openGL workaround linked by a staff.
the launcher instantly crashes if i do that.

inside the zip there is:

-all the logs the launcher generated today

-a dxdiag i did just before writing this [ as i’ve installed others things since the last one provided right after my fresh install of win10 ]

  • 2 events from the event journal of windows. not sure if i have the right ones, but i took the 2 latest event related to unreal launcher.

thanks a lot for your help !

so here are my logs

Hi BobSlay,

I’m linking another users report that is having a similar issue with the same card.

This is what I just suggested to him:

I know that graphics card is quite new but is there an older driver available that you can roll back to?

Is there one available?

Also, are you using Visual Studio at all? If so, what version?

Does the AMD driver actually crash, which causes UE 4.8.3 to exit? That’s what is happening to me.

Hello TJ,

i’m not using visual studio.

As for the drivers version, i think i had the 1st one out for the card, while i was on win7. I had to download separate driver package because the main driver package did not support the card yet. While still on win 7, i had an update about around win10 was officially available, at the end of july. This was part of the main package. Both drivers behaved the same way.

As i installed win10, i did not take note if i had the same driver version as the last one i used on win7. A peak in both my dxdiag linked in the previous thread could answer this if it’s worth to check.

I know i noticed win10 did not install the exact same driver version number than what was advertised as latest on amd website, by it may be a matter of stable vs beta version, or simply a matter of a different order for the numbers. i’ll try to dig there tomorrow.

As teak421 said in his thread, i’m quite aware this is a new card and therefore it most probably a driver issue.
However, so far, Unreal Engine is the only application causing a crash. But as i’m on a quite new computer, and i have quite a low bandwidth cap allowed per month, i did not try that many applications yet. I reset on the 23rd, so next week i should be able to broaden this.

it’s more a matter of making you aware of the trouble than me wanting a fix at this moment. and maybe make AMD aware too.

on win7 i was able to code in blueprint without too much hassle, i crashed only while testing. So whenever 3d was rendered on screen, it was risky. From standalone game or viewport. i’ll see if i can still progress in blueprint on win10.

The video driver crash, windows does not crash and successfully restarts the video driver. After a… 3 second black screen.
The editor is already gone, and the launcher becomes unresponsive.

As other mentioned having chrome open and the theory about both wanting the same ressources, i tried to use the editor with nothing else,right after a reboot. i even closed the launcher.
But it does not seem to change anything.

If i crash, and restart the launcher and the editor and redo exactly the same thing, the editor seems to crash at the same moment. For example, i could crash it exactly on the frame my newly imported static mesh was dragged on the viewport to place it in my map. 3 times in a row. a reboot of the computer seemed to have changed something and i could go so far as place my static mesh, only to crash about 2 seconds after moving to try and go look at it.

when i was on win 7, i was working in blueprint and mainly testing the hud with umg, i don’t recall having crashed while only messing in the hud, but i was easily crashing when looking around or shooting [ i started from 1st person template] sometimes when shooting rapidly, or sometimes when a ball hit a block [ physics enabled or a wall [ static mesh ]

i also managed to crash it once by opening the editor, change a scale value of a volume, and as soon as i pressed enter.crash.

Okay, in the meantime I’ll resolve this report. I’ve made our compatibility team aware that there is hardware/driver conflict with this card and UE4. Hopefully it will be addressed with the next UE4 or AMD driver update.



Thanks TJ !

i have just submitted a report to AMD using

i will wait until 4.9 and the next driver update from amd.

I got about 8 hours of work in before a crash without Chrome loaded… So, I thought I had something…But, it turned out I was wrong because when I ran certain tutorials it crashed every time with nothing loaded.

At this point I keep checking (daily) for a new video driver. Yes, its odd that the driver crashes only in 4.8.3 but not sure what else to try. Windows 10 doesn’t help either… Sure the driver is immature. Please post here if you figure something out! Thanks!

BobSlay… FYI, I tried 4.9 preview 4 and it crashed even worse…

try this: as soon as the editor loads, put your viewport in wireframe instead of lit.

i haven’t crashed yet while in wireframe.

and after not crashing for a whole 3 minutes of constant moving around and adding simple static meshes, i put it back to lit, and crashed within 4 seconds of moving around.

i wouldn’t know if wireframe gives a lot more time before a crash because it sollicits way less the card, or simply because the exact thing causing the crash is not rendered while in wireframe…

i could also, it seems, safely put the viewport back to lit, and back in wireframe without crashing. As long as i don’t cause a refresh of the viewport by moving around or adding something in the map while it is lit. This would be consistent with my past experience while i was on win7 and worked on a umg interface. I was not crashing while in blueprints, or testing in standalone game. But [ in standalone game] as soon as i shot some projectile for fun, or just moving around in the map [ using 1st person template ] i usually crashed.

it’s only a theory so far, i have not put enough time in the editor in the last 2 days to be confident about it.

Thanks for trying that! So i will not spend precious bandwidth on downloading the 4.9 preview.

I do not know for how long you have this videocard, but did you ever crash in another game/ application ? Because i have not yet. I have the card since mid-july, but because of bandwidth, i only tried 2 games and unreal editor, so i’m not really a big sample yet.

While video driver seems a most likely culprit, it may also be something unusual unreal engine does. I just want to avoid a situation where epic waits for amd to fix driver, and amd waits for epic to fix application. And us waiting indefinitely.

No issues to report…But, honestly, I’ve been Unreal Editor most of the time when on my PC. The only time its crashed is in UE…

Excellent catch! So, this happened on Windows 7 as well…?? I don’t remember this happening to me. But, I wasn’t into UE as I am now.

Something in UE is not liked by the AMD video driver. We have the exact same video cards, I wonder if anyone has reported this with other AMD’s? I’ll search around the forums.

Sapphire R9 285 and exact same problem here.

I was experiencing the exact same problem with my R9 285 Dual-X Sapphire card.

This is how I solved that;

  • Open Catalyst Control Center
  • Select “Performance” from the right menu
  • Select “AMD OverDrive” from the slide down menu
  • Change “AMD OverDrive” state to “Disabled”

No more crash now.

(Win7x64 - UE4.8.3 - AMDFX8370 - R9 285 Dual-X Sapphire)

Guys, I am wondering if we should make a new summary thread because this APPEARS to be an issue with UE. Why?

  1. Driver does not crash in other programs.
  2. Driver crashes in a certain function (viewport movement).
  3. We’ve had several AMD driver updates each showing the same issue.
  4. 4.9 Preview 4 (at least for me) crashes even quicker.
  5. Any other logic I might have missed.

One question… Are we all using UE 4.8.3? Anyone getting this issue with older version of UE? I might download 4.7.6 and try it.

Maybe we could give them a project that always fails or create one and upload here so they can reproduce the issue?


Hi teak421,

This issue seems confined to the AMD R9 380 graphics card, which makes me suspect that it is a driver issue. I’ve made our Compat team aware that there is an issue with this card and it’s being investigated.

However, to help get the fastest fix possible, you may also want to make AMD Support aware of the problem.

I only installed the video driver, not the full catalyst package. Si i did not have the option of AMD overdrive. I would presume there was no overdrive with only the display drivers.

But i went ahead and installed the latest whole package, and disabled the overdrive.
There is no noticeable change for me. It still crashes on my R9 380.

  1. no crash in other programs, but maybe we just did not tried enough other program yet. But so far, i agree.
  2. i would widen the crash condition to anything rendered in 3d with a change on more than 1 consecutive frame [ not only viewport ]:

I can crash easily when i launch in standalone and move around. No viewport or editor showing on screen.
I did not yet crash right at the opening of the project [ where the editor renders at least 1 frame on the viewport before i can do anything ].
I did not yet crash if i’m not interacting with the 3d viewport, but doing blueprint in the editor.
I do not crash if i launch in standalone and i don’t move or shoot [ i’m testing with 1st person template ].
I do not seem to crash if i move in viewport while it is rendering in wireframe. I also did not crash yet by moving around in wireframe, and then put it back to lit.

The 2 questions i would try to answer if i would be the one to try and fix this thing:
Is the crash happening in the parts where “lit” and " wireframe" differs [ polygon drawing, light calculation, texture/materials, etc] , or does it seems more stable in wireframe only because wirerame is way less taxing to do.

From my [limited] understanding of rendering 3d, it should not make a difference for the computer whether i’m staying still or moving around. It is still drawing the same amount of frame per second on screen. So what is happening differently when moving around ?

3.yes. at least 2 for me.

  1. have not tried that, and will not try until it is not a preview anymore. Unless somebody tells me it fixed the problem.

  2. i am on 4.8.3 at the moment. i think i had 4.8.2 for a while in july.

As for the project that always fail… Well i would say the 1st person template crashes as much as my project.

steps: create new project with 1st person template.

move around in editor viewport. usually crash within 30 seconds.

if not, drag some static mesh form the content browser into the viewport. usually crash after 1 or 2.

If not, continue moving around.

And by moving around, try to include the whole scene, then look away, then look back, then look away.

Usually, i am crashing pretty fast, but when i am lucky and last about a minute while moving and looking around, i tend to finally crash when i switch from having nothing in my field of view, to having my whole scene in sights.