Ambiant Sound / Complex Shape

I’m currently creating ambiant sound for a game.
Many situations require to combine multiple ambiant sounds to cover a specific zone. However, some ambiant sounds cross over each others and duplicate the instance of the sound. How can I always keep one instance of a sound ?

Soundcues have a “Max concurrent play count” that you can set to 1 if you want, as well as options about how to turn extra instances off.

Theoretically this should work but setting “max concurrent play count” juste seem to disable all ambiant sound except one (not dynamically).

I tried all resolution (stop oldest, newest, farthest) and still only one ambiant sound is working if set to 1 (the ambiant sounds do not pass the instance to each other)