Always playing property of sound class not working in UE 4.13

When i exit the falloff distance of an attenuated sound cue volume and come back, no sound plays… I Even tried setting the sound class to always play but it still does not do what i need it to do. So is there any other way to make a sound continue playing within a specific radius so that when i come back into the radius, it plays from where i last left?
Also the the setting of the sound class to always play use to work in previous versions of unreal.
I’ve already tried this and it still does not work. How can I resume an out of range sound when the player comes back - Audio - Epic Developer Community Forums

Yes I’m experiencing this too. I tried making my own Master > Child sound classes and enabling always play on the Child in a newly created 1st Person Shooter template and when leaving the falloff zone, the sounds re-trigger from the beginning.

I have the same problem, and its really hard to make a musical FPS without this feature…

If someone have a solution or an engine fix pls !

This functionality has been replaced with Virtualised Sounds, but always play options remain and don’t function as far as I can see.

Enable master Virtualised Sounds check box in project settings > Audio, and tick the “allow sounds to be virtualised” check box on each SoundWave.

I will be profusely reading the changelogs from now on!

This doesn’t seem to be documented anywhere though really.

Hope that helps,

Oh ! Thank you very much !

It’s perfect !

And effectively, the documentation should be updated ^^.

Ok, a little more information :

If you want to use the virtualised sound on a multiplayer project, the server heard all the sounds (after leave the falloff radius) but not the clients.

The client enter in the audio’s radius, the music is hearded, he leave the radius , the music is not hearded and when he come back into the radius the music stay not hearded.

You need to use virtualised sound, annnnnd, i cant explain why, check the “Always play” checkbox in the class.

Thank you very much, it works.

Thank you very much!!! It works perfectly.

Do not work for me in 4.15.0

Don’t work for me, 4.19.1

Or for me, 4.19.0

For me as well in 4.19.2

Yeah this doesn’t work in 4.19 unfortunately…

This doesn’t work in 4.20 :frowning:

I’m bumping this because issue still exists in 4.20… but It doesn’t exists in 4.18??

I’ve attached link with a video below, explaining it a little bit.

Ah, I was just making a test video to show it working and found the bug as far as I can tell.
I did a video and absolutely showed it not working. I then went into Settings > Project Settings > Audio to check that “Allow Virtualized Sounds” was enabled, which it already was (and is by default) however the virtualisation then began working after I’d been into settings.

I wonder if opening the project settings is re-establishing the correct default states?
It’s definitely working in 4.19.2 for me, but only after opening settings.

I closed and opened the project too, and it stuck.

Hope that helps,

I didn’t found “Allow Virtualized Sounds” setting mentioned above in my 4.23.1, but I did set Virtualization Mode to “Play when Silent” for both Sound Cue and its Sound Wave and it works as expected now.

Hope that also helps