Alternate Blend Space can't move

I have a weird issue with my alternate (armed) blend-spaces. At first, I thought it was the animations themselves, but after importing a different set, I have the same problem. This is for a side-scroller project.

Ok, the trouble is that whenever my character switches over to the alternate blend-spaces, they are stuck in idle and cannot move normally. If I jump or switch over while moving, the player will continue on until I perform an action or switch to a stable blend-space. Kind of hard to show the gameplay issue but my character and animation blueprints are pretty much cut and paste with the working blend-spaces.

The issue in the bottom pic above, Anim Graph is that the left machine works correctly but the right two do not. The pics below are one of the state machines with a faulty BS. The blend-space itself actually works inside its editor.



Instead of checking N times a bool, you could just create an enum with every state (unarmed, nunchaku, katana, dual wielding, etc) and use switch pose by enum (setting it in the player character and reading it from the AnimBP.

Does the jump animation affect the whole body or only the bottom part? Do you have different jumping animations depending on the weapon?

I have an enum for weapons linked to the character BP. The jumping is generic atm, except for the katana. I started to add a enum check in in the AB. I mean the character changes stances fine, it’s just that the character won’t walk from an idle position unless I jump first, an then they will walk nonstop unless I sheathe the weapon. Only unarmed and katana stances will move.

Can you please post a screenshot of how you set up the transitions between these states? If the rest is working fine the problem should be there

It’s in the pics above of the Anim Graph. Right now, it’s blend poses by bool. One more note is that while they won’t move, they still turn and face the desired direction but are statues otherwise.

1 Like

I took your advice and switched to a blend by enum method in the Anim Graph. It still doesn’t fix my problem though, with the bottom two poses still being stuck in idle.


1 Like

Can you please show me how did you set up one of these not working poses? (Especially what’s inside the arrows between the poses)

Here is a state machine.


Perhaps I misunderstand the last question, the transitions are the exact same as the working BS.

Looking closer at the animations in play, when the character lands from a jump, they can briefly move with the run animation. It stops cold whenever the walking animation it called. So if I move from Idle, nothing happens, and if I slow down from running it freezes in place.

Fixed at last! Turned off root motion in the idle animations. Problem solved.