Altering structure causes indefinite warnings during compiles

I make use of structures created in editor on a regular basis. As with prototyping sometimes you need to change a struct. When altering a struct that is already used in another blueprint (ex: MyCharacter) character compile will cause following warning that will never go away unless struct is removed from blueprint and re-added after change.

Warning MakeStructureDefaultValue parsing error. Object: Default__MyCharacter_C, Property: TheChangedStructure

workaround for this currently is to remove all references to struct in blueprint. Compile and save, then add in changed struct and hook up everything again. Once that is completed it will do a proper recompile.

This happens whenever you change any variable within struct (name, type, etc) even if variable that was changed was not in use during compile.

If needed I can add some screenshots to reproduce this.

Hi Nitecon,

I tested this in 4.6.1 and did not get any errors. Which version of engine are you using, and is it binary (Launcher) or compiled from source (GitHub)? Can you list your exact reproduction steps for me? Thanks!

Hi @-, sorry this is in 4.7 p2/3/4 (Binary release) Exact steps to reproduce this was:

  1. Create a new structure (Name: TestingStruct)
  2. Add 5 or so different variables to it with default values
  3. Open MyCharacter blueprint, add a new variable of type TestingStruct
  4. Hook graph up in a function or just print vars with print string etc
  5. Compile / Save All
  6. Open TestingStruct & add a new var or remove an old var
  7. Save
  8. Open MyCharacter.
  9. Hit compile (changes found)
  10. Error shows up.

If need be I can add a video for it if you need.

I didn’t get any errors in 4.7 Preview 4, either. Does this happen in a new project, or only your existing project? Does MyCharacter fail to compile?

MyCharacter does not fail to compile it just throws warning, this is in my existing project I’ll try with a new TPP project to see if I can reproduce.

, I’ve also gotten this error message in 4.6.1 several times.

It does not seem to happen in a manner that is immediately reproducible: Sometimes it happens, sometimes it does not. I’d estimate that I’ve seen this only about 10% of time when changing a struct, so there may be some other factor needed to repro this than what we’ve found so far.

I was able to narrow it down a bit though: in both cases a specific element of data structure seems to have become corrupt. By going in to Struct definition in editor and removing elements one by one I was able to find corrupt element. Removing element OR altering it and resaving resolve error message.



Each element of main struct is also a struct ( substruct is what I edited to cause problem). data type I removed from substruct did not have it’s value altered anywhere so it is something of a mystery why only one instance of struct corrupted.

Hi ,

I tried for a while tonight, but I’m still not getting any error from this. If you’re able to get a new project to do this, can you upload it somewhere and send me a link?

Hi all,

We haven’t heard back from you in a while, so I’m resolving this post for tracking purposes. If you’re able to give some reliable reproduction steps or a test project for us to look at, or provide any further information to help us narrow this bug down, please feel free to comment and we will continue looking into it. Thanks!

Thanks , sorry I had to leave on a business trip I should be home again tomorrow and once I get some sleep I’ll try to re-create it.