Alt+Tab off and on will make a UI Only Input mode UMG widget hide the mouse cursor

Branch: Latest 4.8 Release from GitHub

Build Version: Version: 4.8.2-0+++depot+UE4-Releases+4.8

Detailed description of the issue: I have an UMG widget for my Inventory Menu that occupies all the screen and uses UI Only Input Mode. If i alt+tab back and forth, the mouse cursor eventually becomes hidden with no easy way to make it visible again.

Hello xlar8or,

I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Can you provide screen shots of any blueprints that may be involved with this issue?
  4. Have you tried setting “Set Show Mouse” to true?

The Show Mouse Cursor seems to work, but why does the mouse cursor appear the first time ? I would rather have it stay hidden to force me to use Show Mouse Cursor. Thanks for the help :slight_smile:

Hello xlar8or,

I am happy to hear that your issue has been resolved. The mouse shows due to the “Set input mode UI only” node.

Wouldn’t it be better if “Set input mode UI only” had an option for that? Because since it was visible just for using that node, i assumed that internally it had set the Show Mouse option to true and i didn’t need to do that, but that’s not the case.

Hello xlar8or,

I have written up a request ( UE-19301) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for you time and information.

Make it a great day

Thank you very much for the support :slight_smile: