Alt + drag doesn't copy asset

I just started a new project in 4.9 and this is the problem I run into.
Dragging an imported asset to duplicate it with alt creates an empty actor.
I tried it on 2 assets. Selecting the asset in the static mesh component doesn’t work as well, the empty mesh actor created with alt+drag seems to be completely bugged.

edit: I tried some things and it looks like the problem was me using “[” and “]” in the title of the folder the assets were stored in. I guess it’s my fault for using symbols in my folder name but I thought [ and ] were allowed. The tip for naming folders does not prohibit them in any case. I guess it could just be an incomplete tooltip?

Hi bzk,

I have not been able to reproduce this on my end. I attempted to alt drag multiple assets, one of which was placed in a folder that contained [] in the name. All assets seemed to copy as intended. Does this occur in a clean, blank project with no additional content or is it limited to one project?

The project is a 3rd person template with no starter content I had just started yesterday morning, the only changes to the template I had done at that time was affixing the camera to the player model head and importing two static meshes.

I tried it again in the same project today with a folder with [ and ] symbols in the folder name and the problem is repeatable.

I made a new project in the same way just to check if it’s contained to one project again the problem was repeated.

Can you post one of those projects here along with the exact steps you are taking so I can try to reproduce this on my end?

This is the second project I made just to test for the bug. There is an asset - a cube - in the folder.
I dragged it on to the level. Then I dragged it with alt to duplicate it. It created an empty actor. Everything is in the project including the asset and the empty actor.

Hi bzk,

I was able to reproduce this and have entered a bug report, UE-20751, to be assessed by the development staff. For now, I would remove the square brackets from your filepath names to prevent this from occurring.

We just run into the same Problem with ( and ) inside a Folder name. We’re working on 4.12.5, so the bug still seems to be around. Just in case it was already marked as closed/resolved. Not sure whether we can see the status of bugs based on the number.

Renaming the Folder inside Unreal re-enabled the possibility to copy Assets in the Scene Viewer.


Hi uexilon,

This bug has been backlogged as our resources are currently dedicated elsewhere. You can track this bug here.