Alpha texture on an opaque mesh

Is there a way I can resolve this? I’ve got a basic mesh that’s got feathers, and the tips of the feathers in the texture are alpha 0, while the rest is opaque.

You can see in this pic the issue on the edge of the feathers:

I tried setting the material to a transluscent material and then running the alpha channel in for the Opacity pin, but that gives me this:

I get an identical result even if I pass a const 1 in for opacity. Const 0 makes the object invisible, obviously.

I’m not sure how best to go about resolving this

Nevermind, got it :slight_smile: Had to set the blend mode to Masked instead of Translucent.