AllEnabledTickFunctions.Remove crash

Getting insta-crash when trying to open one AI character blueprint. Also if the same blueprint is spawned during playing. I can add it in editor and 3d model and settings look right. But getting crash everytime if trying to open the blueprint. Another AI character allows to open blueprint and having it placed in editor, but spawning during play also cause freeze. Else my project map load correct in editor.

If having those crashing AI blueprints placed in editor, I can start play. After 1-2sec playing getting crash. MachineId F87B756443F95CE9986941A672FE5264, but not getting any visible code in crash reporter.
Here is dump files.

Getting this message in log everytime
[2016.04.01-20.43.36:752][452]LogWindows:Error: === Critical error: ===
Assertion failed: AllEnabledTickFunctions.Remove(TickFunction) == 1 [File:\BuildFarm\buildmachine_++UE4+Release-4.11\Engine\Source\Runtime\Engine\Private\TickTaskManager.cpp] [Line: 811]
[2016.04.01-20.43.36:791][452]LogExit: Executing StaticShutdownAfterError

Certain character blueprints are causing this. Some other are also having the same issue:
“I had a similar issue too, insta crashing when trying to open a character blueprint (not AI) and anything with reference to that blueprint. That includes gamemodes, game instances etc and the 4.11 project crashed upon load.
Took me between 2-3 hours to find out what’s the cause + fix it (luckily just deleting these in 4.10 then converting to 4.11 worked. Plus I wasn’t using the characters anyway). I had some issues when converting from 4.9 to 4.10 so maybe that’s where it originated for me.”

I am recreating mine, anyway there is only few blueprints affected and its good to remake those in cleaner way.

I have remade character blueprints so those dont crash when edited. But still getting random crashes during playing. Havent found out excatly why it crashes and how to prevent it.

I had the same problem when coming from 4.9, I posted it in a different thread but I’m solving a different problem first. Let me know if you come up with anything!

No luck yet. Getting much these spamming messages for various character blueprints:
e.g. ArmedBP_C_27 is stuck and failed to move!

Sometimes it just freezes when playing and that is last thing that is written in log (or about to be written, but cuts after few letters). In game the AI just move fine unless there is other AI blocking their path. Just in case this is related bug.

  • Could you provide the logs from your project’s Saved->Logs folder after you cause the crash to occur again?
  • Have you been able to reproduce this in a clean project? If so, do you have any repro steps we can use to reproduce this issue on our end?

Thank you

Hi, here is the whole log folder. Almost all logs in that end with the crash.

Havent yet tried with clean Project. Going to try adding simple AI character and spawn those near each other and use move to random location. So there would be AI chacters blocking each other to move anywhere. That seem to be causing crash very often in my main Project. I keep looking for repro.

Got also the “is stuck and failed to move!” spam in clean Project, but its not causing crashes.

Instead it seems that if blueprint tick is over 0, that causes the crash. Unless setting it to PostUpdateWork. Happens at least with ai controllers. So far good after that trick. Got the solution here:

That freeze issue might be separate or partially related. I noticed pure casting character from controlled pawn dosent always return character. And that caused freeze if connected to play montage. Have been converting other pure cast back to default and freezes have got much more rare. Not sure if just got rid of all freezes, but dont want to celebrate yet. So far looking very promising.

I will go through blueprints and set those to PostUpdateWork.

Hey thanks for updating this. I actually haven’t gotten that crash in a while. I never do pure casts though just default for everything, I do check is isValid so maybe that prevents the crashes.

Adam Davis helped me with a different problem which may have fixed my Tick crash.

When editing one blueprint now getting the “AllEnabledTickFunctions.Remove”-crash when trying to convert one pure cast back to normal. Very strange stuff that certain blueprint crash when edited and some cant be even opened. Will recreate those.

Let me know if the fix that you found on the forums is working for you, and then I will mark this topic as resolved.

Also, if you have any way to reproduce this issue in a clean project where it is causing a crash, please provide the repro steps so we can get a bug entered for the crash you were experiencing.

Yes, starting to look good now. I will let you know if finding some proper repro.


I am marking this topic as resolved for the time being, as it seems you have discovered a solution. If this issue persists, please reopen this thread with new information, including the repro steps that we can follow to reproduce your issue in a clean project, as I have not currently been able to do so. For any new issues, please create a new Answerhub topic.

Have a great day