All transparent materials won't change base color

I have a cube and im trying to make it transparent when being placed. It works fine, but the material only supports black/0000. Ive ensured its set to translucent, nanite is off, and Used with Editor Compositing is off just like in the previous forum posts. Nothing is working. Then I noticed that every translucent object that im working with suddenly lost its color too.

Here is the graph:

Now, it works perfectly in the preview, but its definitely wrong in the world:

Ive created a material instanced, set it to kinda translucent and green, and it still doesnt work. Idk what settings i couldve messed with that has done this. I did mess with graphic settings a while back for vr support. Could that have done it?

Hi, have you tried to import the same mesh in another level with a basic light setup ?

1 Like

Mesh or material? or material instance?

I just tried it and it works in the new level. WHY??? how did you know? What the hell happened to the other level for it to do that??? thats so weird

Happy it helped :stuck_out_tongue:

My first idea for the troubleshooting was that maybe your lighting was problematic, turns out it might be it :slight_smile:

You should always calibrate your materials in a neutral environment, I always recommend this video in case you did not knew about it UE4 Neutral Lighting Scene Setup - YouTube :slight_smile:

Hope it’s helping

1 Like