All pawns are perceived by AI regardless of bAutoRegisterNewPawnsAsSources setting

In 4.16 (release), pawns are auto-registered as sources for the perception system and there appears to be no way to stop that happening.

Putting this in DefaultEngine.ini as older answerhub posts suggest does not work:


(I also tried DefaultGame.ini just in case)

Here is a blank 4.16 test project that demonstrates the problem - note that when you run test_map, the AI cube senses you (sight) and runs toward you (despite having the above line in DefaultEngine.ini).

Is there another way to stop this (without C++)?

I need to be able to only register pawns when necessary because as soon as my player respawns, the AI are all up in his face before his screen has faded in. I can not disable the AI’s perception temporarily because they still need to be able to go after the other (co-op) player. I could put the player in a “don’t perceive me” state, and then check that in the AI controller whenever it perceives something, but it just seems like a messy workaround (besides, turning off auto-register should really work for performance reasons anyway).

Hey Spoondog,

Sorry for the delay on this one. I’ve looked into it, and determined that it is not a bug.

The solution is to add the following to your DefaultGame.ini:


The other thread contained the incorrect name for the config variable, but using the snippet above should give you the results you’re looking for. Make sure you restart the project in order for the changes to take effect.

Have a great day