Download

All objects are rendered black on Galaxy S4 GT-I9500

I am following the tutorial A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums to build Infinite runner game for android.

My project settings are optimized for Mobile/Tablet with Maximum Quality.
It works fine on Windows 7 64bit.

But I get this while I run my game on android, I see all the objects are rendered black like this :

You most likely need to disable mobile HDR.

I have disabled the “mobile HDR” under project settings -> Rendering.

Still not fixed.

Did you try using scalable settings, many high end settings are not supported on mobile (or will produce odd results like this). Also, have you tried using static lighting (and building static lighting)?

@SamDeiter @KRushin I got it working by “disabling mobile HDR and adding a LightmassImportanceVolume” to the scene.

I recall experiencing the same issue.

First question I have: How is it working in the Editor?

Did you try to change the Lighting asset to Static/Movable?
When I had this issue, I played with the Static and Movable parameters for the assets and then rebuild lighting.

If I recall correct, in my case, I changed it all to Movable and the lighting issue was fixed.

Edit: Ah, you got it working already :smiley: