All .OBJ models imports laying flat

Hi, I’m using UE4 4.9 and every single time I import a .obj file, it is laying on its back, so if i import a window standing up it will lay the model flat on its back. what is happening and how do i fix it?

Hi Chay Hawk,

I’ve moved this out of Bug Reports since it’s not a bug.

When exporting from your modeling program as OBJ make sure that you uncheck the option for FlipYZ-axis.

This will import mesh using Y as Up rather than Z as Up.

This is the exporter from 3Ds Max. Depending on the program used, you should see similar options.

76838-objexport.png

If you don’t get these you can also change the rotation using the Import Options for rotation as well if the former is not an option for you.

Thank you!

Tim