Download

All devices crash immediately on app load

Is anyone else experiencing this? I assumed it was just the project I was working on, but it’s actually all iOS devices and even on a blank project.

I’ve tried attaching a console to the phone and getting the output but I can’t see anything coming back from the app at all, no exceptions, etc.

How would you debug this?

Not tried again recently but I did find that I couldn’t get new 4.20.x AR projects to work (Crash after splash screen)
My project upgraded from 4.19 did work however so I shrugged and carried on.
I know that’s not much help…

Hmm. It’s a clue at least!

Actually now that I think about it, the project I upgraded from 4.19 also loads, but I get a white screen with UMG stuff overtop instead of the normal 3D world.

Turns out it was all projects but there is a fix listed here involving cert settings: Apps distributed internally to our… | Apple Developer Forums

Also fixed the white screen issue, switched to Metal 2.0.

Thank you very much for sharing this.