All bsp/meshes just turned black and transparent

I was working on some character blueprint code and saved and closed UE4 down. When I came back and loaded level (which is just Example_Map) everything was either invisible, or black with transparency. I tried loading a different level and same thing happened again. If you click randomly a couple of times then things start to completely dissapear (turn invisible) until all you have left is sky sphere.

Selecting meshes in outliner brings individual items back into view, however as soon as you click off them it reverts back to display below (or invisible).

I’ve tried Show>Use Defaults in case I’d hit a hotkey but that hasn’t worked.

This happens in editor viewport, simulate and also actual game play.

Any suggestions as I’ve not seen anything like this before.

Hey sciffe,

Can you try Building scene? Does this happen in other projects or just this one? Can you open a create a new project and see if same thing occurs? Thanks!

Sorry I’d forgotten to say that I’d tried building scene.

I’ve now opened my other project I’d been messing with and it’s rendering just fine and also I’ve now created a new project based off of first person blueprint so that I could see how example map rendered in it and it also renders fine.

So something seems to be a bit awry with one project.

I’m not sure what would be causing that. Would you mind reopening project, and if it it still occurring after clicking on actors in level, can you attach latest log file? And while it’s not likely, I’d like to see if Blueprint you were working on had anything to do with it. Would you mind attaching that .uasset as well? You can these up and attach them or put them somewhere I can download.

Your dxdiag would be helpful as well. Thanks!

Okay I was just preparing to upload files when I discovered that left, front and top cameras were working correctly. Casting my mind back it suddenly dawned on me that earlier I’d been modifying near clipping plane setting, and sure enough when I checked out its property it had managed to go to 0.0.

Changed this back to correct 10.0, did a full build on level and like magic it all appeared again working as it should.

Hopefully anyone else who accidentally does this to themselves will quickly get to source of problem thanks to my accident.

Oh wow, I’m so glad this thread exists! I did exactly same thing. Loaded my level and everything was just transparent with all the 'billboard’s flattened like early dead Doom characters. clipping plane was what done it - maybe when at 0 value it clips itself into oblivion. Changing back to 10, saving then re-loading was all a-okay, even without rebuilding.


Yep this fixed transparency issue I was having, I guess I set near clipping plane to 0 at some point. problem didn’t show until I saved and closed engine then reopened level to start working on it again.