Alembic Groom Animation Problem

I created a groom for a bear model using XGen Interactive Groom in Maya 2020. However, when I try to animate it, the groom goes completely crazy. Has anyone encountered a problem like this?

At first I thought the groom was splitting along UV seams but this doesn’t seem to be the case, since there is no seem running through the middle of the back. Overall its just not deforming correctly. Any help is appreciated.

1 Like

So it looks the groom is splitting along some of the UV seams but not consistently. It looks like large parts are rigidly parented to specific bones instead of deforming smoothly with the skin.

Got it fixed. I unchecked “Tick Animation on Skeletal Mesh Init” in the project settings. After restarting the editor, the animation works fine. I actually purposely didn’t do this at first because I didn’t see it in the documentation, even though in the tutorials I watched they did it. I can’t seem to find it in the documentation anymore so I’m guessing it was removed for 4.25 but it certainly still looks relevant.

hello, I have a problem,I have a groom,and I created a binding,but I can’t fill it to the blank,do you know why?

Can you send a screenshot? What engine version are you using?

here,I have a skeleton asset,and a groom,also created a binding,but I can’t put this binding to the binding asset blank,so my hair can’t move with the body,thank you,are you Chinese?

It’s strange that it wont let you drag it in. I’m not Chinese but I work closely with someone who is, he could translate if needed. Here’s everything I can think of right now:

  1. First of all, what engine version are you using? The groom system has changed a lot over the last few versions.
  2. Refer to this page and make sure everything is set up correctly: Hair Rendering and Simulation Quick Start | Unreal Engine Documentation
  3. Make sure you import the groom with the correct transform. When I was making the groom for the bear in my post I had to reimport the groom with modified rotations in the import menu because for some reason they were wrong by default.
  4. It looks like the skeleton is animating. Apply the groom on the skeleton without animation, then plug in the animation and see what happens.
  5. I don’t know if it’s still required in 4.26, but in 4.25 you need to activate Tick Animation on Skeletal Mesh Init in the Project Settings.

  1. If none of this makes a difference my next question would be how did you make the hair? The whole system is pretty sensitive, at least in 4.25.

Thank you.In this project ,it’s 4.26 version,I have done everthing as the DOC said,also I have tried to activate Tick Animation on Skeletal Mesh Init in the Project Settings,it dosen’work .
And I have tried to change a computor to do this,or tried to do this in the meerkat project,it dosen’work either.
Also I have the hair which made in maya with exgen,and the eyebrow made in C4D,none of this didn‘t work.Now you said this,if the engine is OK,I think it’s possible ,it’s my groom didn’t do the right set.Is there somthing I didn’t do to export alembic? or something important I didn’t notice when I made the hair thing.

Sorry for the late response. What I did for my bear project and what I would recommend to you is to get a groom working correctly in a very simple test case. I started out with a basic sphere in Maya, made a simple groom to test out XGen, and then imported them into unreal:

Try to get that working correctly with a binding. I believe you can force unreal to import static meshes as skeletal mesh, which would let you create a binding asset for something like this.

Thank you for your help,it’s finaly worked on 4.25.4,maybe the new version has some bug.