AimOffset yaw not working, Preview not showing

I’ve created an AimOffset (normal, not 1D) for my Character skeleton and the preview showed up fine but as soon as I put one of my Aiming animations there the preview simply disappeared, I made sure all of my animations additive anim settings are correct, I set Additive anim type to “Mesh Space”, Base Pose type to “selected animation frame” and preview animation for each one but they don’t show up on Preview for the AimOffset for some reason.

I Ignored the issue and set them anyways and I setup my Animation Blueprint like this :

I also made sure the Pitch and Yaw values are driven by the Rotation of pawn in the event graph

I even checked for Yaw references to see if anything else is affecting it but it’s only referenced where It needs to be, Pitch works fine both in Preview and Ingame, But yaw doesn’t, It’s weird since every Animation seems ready to go, I tried restarting UE4 and it didn’t work either, I’m stuck and I dunno how can I fix this ? The AimOffset works fine ingame too but the Yaw still doesn’t change and my character can only Aim Up and Down, Little help please :frowning: