AimOffset Not doing anything

So for whatever reason I can’t figure out why my AimOffset isn’t working. I am using a 2D blendspace. With pitch and yaw as the axis. Here is my code for calculating the Offset:

FRotator AMyCharacter::GetAimOffsets() const
	const FVector AimDirWS = GetBaseAimRotation().Vector();
	const FVector AimDirLS = ActorToWorld().InverseTransformVectorNoScale(AimDirWS);
	const FRotator AimRotLS = AimDirLS.Rotation();

	return AimRotLS;

Then I implement it in MyCharacterAnimation blueprint:

So I call my function, break it into “pitch”, “yaw”, and “roll”. Then I set the pitch and yaw. However when I play, there is zero aim offsetting going on in any direction. I watch pitch and yaw as they feed the AimOffset Blendspace, and they sit at 0 the whole time. I am not sure what it going wrong


I would recommend you checking the values step by step, so do the following as a starter:

On the event graph, do a print after setting the Aim Pitch and Aim Yaw to check if the values are correct. If they are then problem is more towards the aimoffset asset or the animation graph, if not there is something wrong on your Aim Yaw and Aim Pitch calculations. Check on the anim graph if it’s applying the additive Aim Offset node with the Aim Yaw and Aim Pitch as parameters like this:


Okay so I did what you said and you were right it seems to be a problem was not with the values but with how I implement my AnimGraph. I am trying to use the “Apply Additive” Node like you suggested and it disfiguring my character

Wow, something is definitely wrong there lol Try just connecting the state machine to the Apply Additive (with the aim offset directly) to the final pose. Start eliminating the different possible causes for that.

I tried what you said. It is definitely a problem the apply additive node. When I change the value to 0, my character work (except for AimOffset) but as I increase that value my AimOffset starts to work but my character become increasing deformed… Still no solution.

I noticed that you are using the Blue Guy, what Aim Offset are you using?

I have custom animations so I made my own aimoffset. But I am using a compatible skeleton, and skeletal and animations. I followed the tutorials on how to make an AimOffset blendspace and I don’t see a difference between mine and the one from the shooter game. This a very odd and frustrating bug.

Indeed, you can check the Shooter Game to see if you’re doing the aim offset and the Apply Additive in the correct way. Worse case try to import the character from the Shooter Game and see if it has the same issues.

I found an answer to my problem. It has to do with how you set up the individual AimOffset animations. So in case anyone runs into this same problem, here is how I fixed it.

The “AdditiveAnimType” must be set to “LocalSpaceBased”


  1. Open the Animation
  2. Scroll down until you find “Additive Settings”
  3. SetAdditive Anim Type to: Local Space
  4. Set Base Pose Type to: Selected Animation Frame
  5. For Base PoseAnimation: (select some idle animation)

Hope this helps anyone who stumbles onto the page. Good luck!

I’m glad you solved the problem :slight_smile: