Aim Offset ue5 problem

Hi everyone,

I tried to do aim offset in UE5, but it seems to be stuck on one animation out of the 3 I have in my aimOffset1D. Did you have this bug also ? Or do you know if something has changed compared to UE4 ?

Thank you :slight_smile:

1 Like

Seeing the same issue in UE5EA. 1D Aim Offset seems “stuck” one one animation. Seems to be an issue with additive animations not wanting to blend even in the preview graph. Any solutions?

1 Like

Yeah I came to the same conclusion. It seems the additive animation layers are not taken into account. However, if you export using preview mesh, the additive animation layer we will be bake in the animation

Hey, is this the solution? Can you describe it more please?

Yes basically if the additive animation layer is playing on the editor but is not taken into account in game, you can export the animation by using preview Mesh. It will export your animation in .fbx. And if you import it back the additive animation layer will be taken into account

Yea, hello, I have a question on the topic of Aim offset 1D. Is this normal?


if this isn’t, which I’m guessing isn’t, how can I fix it?

Is this still the case? I’m experiencing this problem now after upgrading my project from 4.27 to the latest ue5. I’ve noticed I can’t even use the preview value crosshair, it just doesn’t move at all lol And the anims are all stuck and jittering.

FOUND SOLUTION I THINK


Go to your animation settings and change the base position. In my case problem solved with this. After doing it mesh disappeared from AO preview screen but it worked in the project.