AIController and Car will not move?


how do you get an ai to drive a car?
do i have to use backboard and all that nonsense? because i dont want or need to, its an extremely simple test.

what i have tried so far is from an AIController blueprint,
get the car pawn (also tried getting movementcomponent) and set throttle value
simple move to
move to

the car is being possesed and the controller is ‘alive’ but it doesnt move. i dont need any pathfinding so i unchecked that in the moveto test, still didnt move.
any hidden checkboxes or anything i should know about?


Did you add a Navmesh Bound Volume in your map ?

This is a volume found in your top-left corner window. It calculates what zones an AI can move on and it is automatically updated when adding / removing blockers in the editor.

You can reveal / hide the green pathing it will generate by pressing “P”.

do i have to use navmesh? because i dont want or need to

Why wouldn’t you want to use it? :stuck_out_tongue:

I think there needs to be Navmesh Volume in order to get the AI moving.

because i dont need it for what im doing.

i have solved the issue anyway,
setting throttle from within the ai does not work. so i created a new function in the car to set the throttle then call that function from the ai and it works!

many thanks for the replies Yun-Kun

Hello Tegleg, I´ve followed a lot of your tuts in the UDK forum (namely setting up a car based on the scorpion class) which helped me a lot. In UDK I could get AI cars to go around using Kismet without problems, BUT in UE 4 is a different affair - I´ve always suspected that one could get an AI vehicle to drive around only using the move to function and path nodes. Could you please show a blueprint explaining a little better implementing what you´ve discribed above. I´m asking you cause your probably one of the few users that figured it out and cared to mention it. So thanks in advance Tegleg

Could you please reply Tegleg…