Download

AI Standstill in a Mod Shooter Prototype

Hello Guys,
I am very new to UE4 and Game Dev in general, though I do have some mildly decent grasp of C++. I was trying to add a level to the shooter prototype game, when I got this problem. Everything works fine when I play and launch my custom map from the editor. But once I use the package option to make a “WindowsNoEditor” game for test, the level loads properly however the AI just stand still while they are shooting. They don’t move at all as though they are stuck or something is missing. I wonder if I am missing something, since I get all fine results when I launch the stand alone game from the UE4 editor. Only then I do the packaging.

  1. So what potentially could be the issue here folks ?
  2. Does it have something to do with the packaging functionality of UE4 ? I personally don’t think so, hence am I missing some set up when I try to package ?
  3. Or it has something to do with NavMesh bounds volume and the generated common Nav volume ? Because I have seen sometimes the settings of this get screwed up with my large map and even when launching from the editor I get the same stuck AI behavior.
    Does any one else gets this kind of issue ? I will be grateful for any advice, recommendations, directions or suggestions.

Alam

I more thing I found with that packaging issue I was talking about above, although my sound plays where ever I placed it in my level, those locations where I had placed video materials , I mean materials made out of media files, are not shown in the packaged game when I ran it on another machine. Does any one in the community tried to package the game and found some stuff missing ? So far I have not resolved this issue yet, but I think I will try this with multiple projects on more than 1 PC. Till then any suggestions are welcome.

DId you make a nav mesh?