AI rotation is too sharp

Hello so im real bad at AI and its taking me forever to get them right but so far its going somewhat alright.

The one thing i cant figure out is why the AI has such sharp rotation is there a way to smooth the AIs rotation for example when it rotates it does not
actually look like it rotates it just changes the degree of where to go and goes there i want the AI to actually TURN to where it wants to go.

Thanks

Disable “Use Controller Rotation Yaw” in “Pawn” settings
Then change Z “Rotation Rate” in “Character Movement (Rotation Settings)” to what you like

4 Likes

Worked like a charm thank you delightfully

A small remark - you also need to disable OrientRotationToMovement and enable UseControllerDesiredRotation in the Character settings.

3 Likes

This worked like a charm! Ty both!

… here is full details on solving issue:

1 Like

Thank you! I have been pulling my hair out all day trying to solve this…

1 Like