AI Perception Debugging Broken in 4.19?

Below is a screen shot of my character pawn and another BP that has a AIPerception component with sight.

I activated Perception in the Gameplay Debugger but do not see any visualization for it. Am I missing something or is this a bug?

Have you pressed numeric keypad 5?

You need to have the AI character in the middle of the screen when you press the [ ’ ] key.

So the ai perception is attached to a regular actor, not an ai agent, I think this is why, since stuff seems to work when the gameplay debugger has an agent set.

The ai perception component is not attached to a character

You don’t understand, you need to LOOK at the AI character (in your viewport) before you press the " ’ " key (that triggers the AI on-screen information).

Do you see in your screenshot where it says “Debug actor: None” (top right corner of the screen)? That means you pressed the " ’ " key without having that AI character in the middle of your viewport. But hey, thanks for the downvote…

The AIPerception component was designed to be added to the AI Controller blueprint, not on the character itself. Straight from the Lead AI programmer over at Epic: Getting Started with AI | Live Training | Unreal Engine - YouTube

If anyone wondering, pressing 4 on NumPad worked.

Seems like this is bugged in 4.26.2. Pressing apostrophe or the numpad 4 key does nothing, no AI debugging at all. I’ve worked with AI a million times so I have no idea why this isn’t working

Definitly bugged in 4.26 whatever i try, just cant get the debug sight vision cone to show up