Download

AI pawn can not move when I spawn 60 - 80 pawns

I’m using Unreal Engine 4.14. When I spawn 60 - 80 AI pawns, my AI can’t move with “AI Move To” BP node… But when I reduce it to 10 - 20 ai pawns, they can do it. I checked all things like NavMesh, accepted radius, collision, using “simple move to location”, … but it still stuck. The failure result show to me is “abort”… Do you guys have any suggestion?
.
.
.
ps: Sorry about my english…

I think there is limit to how many AIcontrolers you can spawn at once. I think when you use blackboards that limit is higher.

I would use newest engine version and see if the problem still exists. They made improvements around 4.16 when instancing many ai characters I think. I thought multiple pawns of same class share an instance of same ai controller? I would definitely use a behavior tree with small delays like above mentions and keep “move to” off of event tick. You could even try using blueprint nativization exclusive to just the ai, its in the project settings menu and see how much it speeds up the calculations.

Tran Thanh Thien - you come from Vietnam?

This problem was solved by increasing Max Agents in “Project Settings > Navigation Mesh > Config > Max Agents” … When I spawn higher than 50 pawns (that greater than Max agents number which default in config) then some of it will get trouble… To fixing, just increase “Max agents” higher than the number of spawn you create…

Thanks for your attension

yah…