Download

AI Pathfinding doesn't reach goal (besides there is an obvious path on the nav mesh)

Hello all,

This is my first post here after almost 2 years working by myself with UE4 and fighting with every bug…but these days I’m so so tired. It would be awesome having a little help from any veteran guy.

I’m working with this simple test code:


(It’s on the controller blueprint of the possessed pawn)

Okay…so, I have a mountain with an obvious pathfinding to the top but the pawn is not able to reach any location over the top, if the initial position is the other side of the mountain. Allowing partial path the pawn reachs the base of the mountain and then it stops.

But if the initial pawn’s position is on the mountain’s side in front of the path to the top, everything works fine.

This is the navigation of the path to the top:

I share with you more pics of the level:


The million dollar question is:

Why can’t the pawn reach the final location in the first test? Any solution?

I blow my mind trying to answer this :frowning:

Thank you so much for any help you can bring to me.

Kind regards,

DMM

Maybe slope is too steep? There is a setting on movement component for that. Other reason can be actor radius, not fitting through narrow passages. You can also place nav links in places for ai to try and jump over gaps in nav mesh.

Thanks for your answer but I remember you that the pawn is able to reach the top. The problem is when it tries to do it from the other side of the mountain. (of course the values that you mention are already modified)

Today, after another search session, I have found something quite interesting. I think that maybe this is the solution to my problem:
(https://www.reddit.com/r/unrealengine/comments/fo5bpz/how_is_the_maximum_navmesh_pathfinding_distance/)

Another even more interesting post (from the solution point of view):
(Long navigation path issue - UE4 AnswerHub)

I will try these.

Cheers

Okay, fixed! :heart_eyes: I did these two steps in order to fix this “bad ■■■■■”:

  1. Go to your DefaultEngine.ini inside your project’s folder location and add these lines at the end of the file:

[/Script/NavigationSystem.RecastNavMesh]
RuntimeGeneration=Static
DefaultMaxSearchNodes=4096 (added this line to the file)

[/Script/Engine.RecastNavMesh] (added this line to the file)
DefaultMaxSearchNodes=4096 (added this line to the file)

  1. Then go to your recast navmesh (World Outliner) and change Tile Size UU to 4096

I wish this post could help someone.

Cheers!