AI not working with multiple possessed enemies

Hi! I’ve followed a serie of tutorials in order to create a simple AI that chases the player if close enough, and wanders in the area if the player is too far away. It (mostly) works if I place one enemy in the level, but when I place more than one of the Character blueprint it stops working. I guess it is just because all of them uses the same set of variables (that are not arrays in my case) and get in conflict with each other, but neither this tutorial nor any other I saw seem to consider the problem, so I don’t know if that’s actually the problem. I would have a lot of images to post, showing my blueprint flowchart, so in order not to confuse my post I’ll post them only if requested. I’ll just post some of them.
This is my Behaviour Tree

This is the Service that makes my AI search for the player

Thank you for any suggestion!

Make sure your BB keys are not marked as “Synced”. There seems to be a bug in 4.12 that makes all new BB keys “synched” by default.



I’ve just realized you’ve marked your post as 4.9. The comment still stands, though :slight_smile:

Thank you for your answer, but unfortunately it looks like my keys are already marked as unsynced. I do not really know what might be the problem. If there is anything that I should post here to help understending what my problem is, please tell me. Thank you in advice!

Hello, I believe I used the same tutorial as you did, Digital Tutors? Been working on a demo for a class and had the same issue. I took this from another question thread and it worked for me, create an “Event Receive Activation Node”, hook that up to a “Get All Actors of Class Node”. In the “Get all Actors of Class Node” choose actor class as whatever your AI character was, I tried putting the AI controller here but it didn’t work (Enemies would not attack each other, but still would not go after the player).Take the “Out Actors” pin from the “Get All Actors of Class Node” to your “Actors to Ignore Pin”. That worked for me. I can’t tell you why this works, but it does for me. Good Luck!

Struggled with the same issue, so after hours of headscratching you saved theday!
Thanks a lot :smiley: