AI not walking/running animation when given AIMoveTo

Issue

Steps to reproduce

Start a thirdperson character with UE 5 (5.0.1) in my case and follow this tutorial: AI Random Roam |AI Move To/Basic Roaming - Unreal Engine 4 Tutorial - YouTube

You will end up with something like this into your AI character

Question

How can i enable the walking/running animation when ai is moving to destination

6 Likes

Hey @Paolo_Falomo! You may need to create a custom animation blueprint for your NPC. Here are the docs that should get you set up!

2 Likes

Thank you @Quetzalcodename, i am using the animation blueprint given from the ThirdPerson UE5 assets

I have somehow discovered a “workaround”:

  1. Be sure you are using the animation blueprint
  2. Go edit the animation blueprint (in case you are using ABP_Quinn u’ll se that you must edit the parent one (the ABP_Manny, the male one)
  3. Somehow the Get current acceleration returns always false
  4. So simply cast to your custom character BP, on cast failed leave everything untouched. On Exec just checks the groundspeed

This is not a solution for me, it is a workaround. :face_with_diagonal_mouth:

In your AI’s movement component, tick Use Acceleration for Paths and it should work with animation blueprint. You might need Requested Move Use Acceleration enabled as well.

30 Likes

@zeaf Great! That’s the solution. Thank you!!

It also helped for me, thx

thank you!your solution helps me a lot!!!

1 Like

Setting “Use Acceleration for Paths” On solves the issue no need to edit the Animation Blueprint.

I’ve checked UE4.27 and having the same value set to ON is not required. the Ai moves the character just fine.

Must be some change for the 5.02 version as author of the tutorial on unreal documentation didn’t need that.

Unreal should have some comment area on the documentation sites. All this info is spread everywhere and not easy to find

5 Likes

Brilliant, thanks @zeaf.

@dorusoftware yep agreed, this solution was buried! Needed to be clearer

This has just saved me from a massive headache

1 Like

@zeaf
great! Thank you from Japan

1 Like

Thank you! This worked fine in another tutorial and suddenly I had to use this fix for a recent effort.

1 Like