AI not spawning on for loop

You’re spawning them all at the same location - perhaps give them some room to breathe. Spread them out.

Alternatively, adjust the collision settings; so even though they’d spawn at the very same location, they will ignore one another.

my SPAWN AI FROM CLASS spawning only one ai on for loop