AI moveto deceleration isn't working

After a succesful AI Moveto command my character just seems to stop instantly without taking the deceleration and/or friction settings into calculation at all. I don’t have a clue why this is happening. I’ve posted a picture of my very simplistic setup. I’m very new to the engine so I also don’t know how to come up with custom deceleration/friction systems for my characters.

I’ve tried searching about this and it seems that I’m not the only one with this problem.


Deceleration is currently not supported for path following. This request does exist in our system as UE-17495, but there is currently no timeline as far as when it will be implemented.

Have a great day,

Sean Flint

Thanks for your answer. What should I do to make it working then? The stopping looks very jarring and has to be fixed somehow.

You could attempt to do something along the lines of getting a reference to your Character Movement Component and then lowering the MaxWalkSpeed as the Character gets closer to the target location. However, keep in mind that if you change this value, you’ll need to reset it to its default in order for the character to move at full speed again once they reach their destination.

Hmm, alright. That’s gonna complicate a very simple thing. Thanks for the replies, though. I’ll try experimenting with what you said.

Stuck on the same problem. Clapfoot found a solution and it works

In PathFollowingComponent.cpp, line 51, set bStopMovementOnFinish to false.
Path following will still work.
That’s it.
PS.: you need the engine source, of course.
Maybe Epic can expose this variable to blueprints in future releases?

Thanks for the answer. I’m not really experienced enough to do this, so I’ll just stay in hopes that the people at Epic will fix this at some point.

Hi Sean,
I have this issue too, and deceleration not working on my AI character,
I using 4.10.2 …
I couldn’t find UE-17495 on portal, what’s happened to this issue ?

It just needed to be made public. Here you go: Unreal Engine Issues and Bug Tracker (UE-17495)

i just started using Unreal engine (version 4.15) and i ran into the same issue. Has this been fixed?
Best regards

Hey mihovil,

This flag is accessible under the CharacterMovement component in the Nav Movement section of the details panel “Use Acceleration for Paths”. With it enable the AI controller pawns decelerate when approaching their target point.

This does nothing.
Checking or unchecking “Use Acceleration for paths”, checking or unchecking “Use Fixed Braking Distance for paths”, setting a value of 0, 500 or 1000 in the “Fixed path braking distance”, makes an AI to stop immediatly when it reach its destination after the “MoveTo”.
Do we need to change other deceleration/friction settings in the CharacterMovement component?

Hi Haoris,

I tested this and I’ve found that checking Use Acceleration for Paths as well as changing the Braking Deceleration Walking setting in Character Movement: Walking gives decent results. You’ll need to tweak the value to suit your needs, but I’ve had good results when setting it to 1100.

Could you give that a try and let me know if it helps?



It looks like it doens’t work for “MoveTo” nodes of behavior tree

In 4.24 “Use Acceleration For Paths” flag works beautifully. Thanks.