Ai Moveto aborted no matter what I try

I have tried both unreal engine 5.0.3 and 4.27.2 and it give the same results
This is what I used for the movement

What is the result of your code?

Did you add “NavMesh” to the Level that will generate a walkable path for the AI?

Without this the AI will not move anywhere :wink:

Once you place it on the Level make sure it covers areas the AI should be able to walk around, press P to see the NavMesh Generation :wink:

Yes there is a valid nav mesh I tried to replace it and it didn’t change the print just says aborted

What is the Vector Value returning here?

Use a PrintString to check if it doesn’t say 0

Also try adding the Target Actor with Radius instead (just to see what changes)

This is what it returns True

Which part is returning that “true value”? :o
aborted comes from the AiMoveTo Enum but the “true” statement?

Maybe I’ll try to recreate your code to see as it’s really weird, you have actually everything

The last thing may be the Actor setup - when you placed it on the map - click it and scroll to very bottom to see how will it behave (should be AI or maybe Player 5, should the AI possess spawned or placed Actors)

If you spawn them - make sure their Defaults have also that setup

woops I put the print sting on get random reachable point i misread your message lol

Here’s something about your issue, the guys describe what may cause it to Abort “without a reason”

Still the same issue

I tried to create a new level and its still the same issue even if its going to a target actor

What is the Possessing setup in the AI?
Are you using AI controller or a Custom AI controller?

What is specified in Game Mode? Are you also using own custom one or the original one?

Ai controller and using first person preset

there’s one that spawns and one that I placed

So you are using same Actor for AI and Player, right?

Then it’s the Defaults setup at the very bottom where you can specify how AI will behave, or if it should be a Player

no the player is the default spawn player the enemy is the cubes


I mean this setup, check if it’s done correctly for your Cube

also does the Cube have any Movement Component or is it just a cube with nothing?

I have that set

And what about the Movement Component?

i had the wrong movement component thank you so much


Finally we got this haha, nice :laughing: