AI Move To will not succeed

This worked back in 4.12, but has not worked in 4.14-4.16. I am using a blueprint only AI and frequently use AI MoveTo node. AI MoveTo will fail repeatedly, but if I loop it to keep trying, it eventually succeeds. I verified start and end points are reachable in nav space. problem with this looped work around is that the AI stutters in between each assignment.

I have tried switching to MoveToLocation, as many questions post it as fixed since 4.13, but in this node the pawn stops moving after two steps and looping does not fix.

Please advise.

How big is the radius?

Do you have a navmesh? Press P to toggle visibility of navmesh.

are you sure the input location that you feed into the node is correct?

I have a nav mesh and verify by visibility that the path is traversable. If I implement a behavior tree the pawn also moves fluidly, confirming this is a problem with the nodes internal pathfinding and not ue4 pathfinding in general. I am certain location inputs are correct by the same test. I have tried varying radius from 0 to 200 in size 50 increments.

The issue here is not with pathfinding as success is eventually achieved as I noted. There is something within the node function which is returning failure and halting motion when a more appropriate status is in progress.

It is a simple shift for me to use the behavior tree workaround but want the devs to know about this (perceived) unintended behavior.