AI Move To Location or Actor doesn't work in 4.12

Hey guys, I have upgraded my project to 4.12 and found out that the “Move To Location or Actor” node does’nt work.
I tried to open new project and use it again in more simple form but it still doesn’t work.
(the other “AI move to…” nodes still work).

other funny thing I found that if im putting couple of AI characters in the scene, that moved by this node, they start to rotate slowly toward the player.


  • Could you provide screenshots of your blueprint setup so I can see how you are using the node and attempt to reproduce it in a clean project?

in 4.11 its work

in 4.11 the script work fine

Could you be more descriptive while saying “it doesn’t work”? I get that AI doesn’t move, but do you get the “request failed” event? How about “on move finished”? Also, does rebuilding navmesh on your level help?

First, thanks for the help :slight_smile:

Second, the behaviour tree always run this node and it doesn’t return faild, if it fail, the behaviour tree will run another branch in the tree.

and yes, I tried rebuilding the navmesh and tried the same methode in a new project and still doesn’t work

when im switching to “AI MoveTo” node it works.

After testing your setup in a clean project, it is working on my end.

Is it possible that your Target Location key is not being set, which is passing an invalid value into the Goal Location?

Try this:
Put print string nodes off of On Request Failed and On Move Finished that say Failed and Success, respectively so you can debug it to see if it is ever failing or finishing. Also, ensure that your scene contains a Nav Mesh, and that your Character or Pawn contains a movement component of some sort.

You tried that in 4.12? beacuse in my case its still not working, and I tried all things.
Here a pic from a clean project and again, the upper node work fine (I even tried to put the player ref as a goal actor and nothing happand).

Could you zip up the clean project and attach it to a comment so that I can take a look at the setup? Be sure to delete the Saved and Intermediate folders located in the project directory to reduce the file size.


I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day

Check if there is a NavMeshBoundsVolume in the map