"AI Move To" Foot Slide Problem

Hi, I created a corral containing 5 pigs, a big one, four piglets, two of them chilling from time to time, and the other two got a slightly aggressive behaviour. Pathfinding, resting and attacking works fine so far. But the piggies always slide through the corral instead of using the walk/run-state of their Anim_BP. After three days of searching forums, changing values or enabling/disabling functions of the character movement, or changing animation rates, I’m pretty desperate right now.

I would really like to stick to my “simple” blueprint scripting without using behaviour trees or root motion. Everything works fine except that ■■■■ “paw” sliding. Here is a screenshot of my movement settings as well as a short video of my piggies, including the sight of my piggy-cam I use to simulate a transmigration of souls. :stuck_out_tongue:


Ahh…I got it! After 3 days of torturing my brain and messing with settings I finally found the mistake. I duplicated my initial pig to create my four piglets, but I didn’t create an individual Anim_BP for them. So they all were using the main pig’s Anim_BP, that referred to that pigs mesh. No wonder that they only slided over the ground. Now the Chillpig has its own Anim_BP as well as the Aggropig and they act fine.

Last problem is that my Blendspace doesn’t work as intended. The pigs are always running regardless where I alter MaxWalkSpeed, I created a workaroud with a seperate “Running”-state, that triggers when Speed is over 300. Works so far, but a working blendspace would be much nicer. Any suggestions?