Download

AI entities won't walk through doors that open.

I am trying to get the zombies to open and walk through doors while going to the player character.
So far they do not even walk through a doorway even if the door is open.
The only way I can do that is to remove the door entity.
This is the bp I am using for the door.
Is there a way to adjust the bp to allow the zombies to open a door and walk through it?
My bp knowledge is pretty weak as I am still pretty new to it.

There are a couple of approaches to this, for instance

  1. Place a Nav Link Proxy, available in the editor ‘Modes’ panel, under the doorway. This will update the default nav mesh if the door opens, depends also on navmesh settings - should work per default.
  2. Use a dynamic nav mesh (see ‘Navigation Mesh’ panel under project settings)
  3. Complex implementation, set the door mesh to a collision which does not overlap/block your AI, but the player, e.g. setup a new ‘Object Collision’ channel under project settings panel, ‘Collision’. This would not automatically open the doors if the AI walks through - hence would require extra work. The nav mesh likely is generated per static meshes and landscape configuration.

All these solutions have their advantages and drawbacks, depend on your project configurations. You should probably use the first suggestion.

“Nav Link Proxy” did not allow the zombie to walk through the open or closed door.
“Dynamic nav mesh” does not appear as a menu item in the project settings.
I may need a video for option 3.
Do you know of a good one?

There is no way to make this work?

@unit23 #2:

By default it’s set to static. Change it to dynamic.

How to get there: check from min 2.07 in https://www.youtube.com/watch?v=UpbaCHTcNPA&feature=youtu.be

I had already tried that and it did not have the desired effect.

Combining dynamic nav mesh and nav link proxy should work, as long the chraracter collider is able to pass through the gap:

I have decided the best way to do it is to simply put zombie spawn points in the rooms I want them to go. I do appreciate the information and perhaps someone else can use it. :slight_smile: