AI doesn't follow a jumping actor in 4.12

Hi !

A character using nav mesh and AI MoveTo stops any movement when the followed actor is jumping or falling.
I’m experiencing this issue from the 4.12 update. In 4.11, my character was following the actor in any moment.

I need a little bit of help on this one if you please.

Hello,

I have attempted to reproduce this issue in a clean project but am not seeing the same results.

Could you provide some more information regarding your setup? Screenshots of your blueprints, behavior trees, or anything other relevant setup would be great, if possible.

Also, if you’d like, feel free to provide a test project. You can zip it up, upload it to Dropbox, and provide me with a link either through Answerhub, or if you’re concerned about privacy, you can PM me the link on the forums: https://forums.unrealengine.com/member.php?160394-Sean-Flint

Hi, I work with NaggAash. Here a test project : Dropbox link.
Thanks.

Hello,

I’ve lowered the Jump Z Velocity of the Character Movement Component to 250, and also increased the Acceptance Radius of the AI Move To node to 250. This allowed them to continue to follow the character.

It seems like what was happening was the AI were unable to get within the necessary acceptance radius of the character, so they wouldn’t execute the move. Give the numbers I suggested a try and let me know if you still see an issue. You can most likely use the original numbers, it will just require some tweaking of the Jump Velocity and Acceptance Radius properties to get it to function as you’d like.

Have a great day

Hello,

Thank you a lot for your time but, if I understand what you suggested, we can’t just modify our Jump Velocity and Acceptance Radius. The player has to jump in high height in our game and AI has to follow him and stops in very close range, something that was possible in 4.11. If we change Jump Velocity or Acceptance Radius properties we will definitly lose this gameplay, am I right ?

I’ll take a look at the project today and see if I can determine the root cause of the issue. As it was a test project, I assumed you were using those values for test purposes, that’s my mistake.

I’ll go ahead and spend some time looking at the project to determine if there is a bug or just some settings that need to be altered.

I appreciate your patience.

I’ve found the solution. You’ll need to go into Project Settings->Navigation System and then add a new Supported Agent by clicking the + symbol next to the Supported Agents option.

After you do this, expand the 0 dropdown, and then adjust the DefaultQueryExtent in the Z axis. I used 5000. After you do this, it should work.

It was most likely an issue with the character jumping over the bounds of the Nav Mesh.

Have a great day

Thank you a lot for your help ! Everything is working as expected.

This was just what i needed! Didn’t find any solutions at first. Thanks!

Another fix, because it never hurts to have a lot of solutions!

Steps:

  1. For the destination vector - get the location of the player, and break it into X,Y, Z.

  2. Make a vector and hook up the X/Y values to the newly made vector

  3. Leave the “Z” value of the newly made vector at ZERO

This will cause the AI to see only the X/Y values - and totally ignore the height of the destination vector - enabling you to have the AI follow the player, regardless of whatever height they’re at!

Hope this helps!

Tested in 4.22.

you are the best