AI debug doesn't work in gameplay on 4.10?

Hi, I press the apostrophe key, and doesn’t open the debugging information in gameplay mode, it just work on simulate, someone have some workaround?


I have attempted to reproduce your issue, but I was unable to do so. In 4.10, when I attempted to use the apostrophe key to open the debugger it worked without issue.

  • Is there any more information you could provide that could assist in reproducing this issue?
  • Are you on PC or Mac?
  • Does the debugger work for you in 4.9.2?

Hi Sean… so, I’m using a PC, and in 4.9.2 doesn’t work too, but in 4.8 it works fine.

I’m using this keyboard, with English International settings, I don’t know if it helps… but its what a have.


I have been able to reproduce your issue, and have entered a bug report (UE-23763). Thank you for your report.

Have a great day,

Sean Flint

Please, do you have some workaround?

When I set my keyboard to English International settings, I was able to get the debugger to appear by pressing the apostrophe key and then pressing the space bar immediately after. Go ahead and give that a try.

Doesn’t works for me, but I changed my keyboard setting to English US and now works fine. But there is another issue, i think. Why the debugging information just works with a camera attached to my player? I’m using a custom camera that is not attached to the player, and I just can see a line below the AI pawn.

Thks for your time. :slight_smile:

What do you mean when you say “using a custom camera that is not attached to the player”? How do you have this custom camera set up?
Can you provide a screenshot of what you are seeing when you use the debugger with your custom camera? Thank you.

So, I made a blueprint that drives de camera, and set the player in runtime.

Look the screenshot what’s happening…

I’ve attempted to reproduce the issue you are experiencing, but when I created a camera that was not attached to the player, I was still able to see the debugging information clearly. Are you able to reproduce this issue in a new project? Also, has this only been happening in Paper2D projects?

Hi Sean, sorry for the late reply, I didn’t receive your question in my e-mail box, and I was really busy in the last months, so i truly sorry for this… well I tried now the bug about the camera on 4.11, and it just gone, just the issue about the keyboard remains.