AI characters push each other and fly around the map. How to fix it?

I want them to chase a player and attack when it is possible. It is based on a Character class. AI Controller has UCrowdFollowingComponent.

I want them to behave like Warcraft 3 enemies surrounding a character and attack. But instead, they push each other.

I guess I could disable some physics interactions, but I tried different options and had no luck. Any Advice?

Hi there,it can be caused by collision settings between melee weapons and character capsules. Are you using hit boxes for dealing damage? I would check that too.

1 Like

The weapon has no collider, and I do not spawn a hitbox to attack, for now, just an animation.

Seems quite similar to the very recently posted popcorn:

Could this be the movement component mishandling depenetration?

2 Likes

Are you talking about collision?

It’s related - yes, but does not, generally, affect characters since the capsule is not simulating physics. The movement component takes over and uses its own values. The behaviour looks like it but may be irrelevant. Hard to tell without seeing it first hand.

In case where an overlap happens between Pawns, how quickly do we eject from the intersecting geometry. The direction depends on their centre, afair. If you have a cluster of actors sharing an overlap, and combined with regular collision, this could produce uncanny behaviours.


You never answered any of my questions from the other thread so not sure how to advice. Seeing a 2nd thread about something quite similar is quite suspicious - maybe this is a bug.

Do the characters perform any actions (apart from moving) that could displace another character? How are their attacks handled (if any)? You posted implementation of launch (was it an enemy actor?) but never commented on it or explained how it was used. Perhaps you ignored it because you know it’s not important here - but it would nice to tell us that. Otherwise we’re stumbling in the dark…

1 Like

The automatic translation on the page was not smooth, so I couldn’t understand the meaning.
Sorry… ㅜㅜ…

1 Like

(how quickly do we eject from the intersecting geometry.)I don’t understand this.
I haven’t touched anything Skeletalmesh, collision, nothing else assigned.
The movement of the character is moved by the behavior tree.
If you want the geometry value in the picture above, I have the same value.

I remade the character from scratch, removed any colliders from mesh in Unreal editor, and set NoColision to every mesh I had in the character component. Now it works as expected. Not sure what helped exactly, but thanks everyone for the help!

2 Likes

I had the same problem.
There is a high probability that the Blueprint, C++ code is not the problem, but the actor lying in the field has a collision problem. Did you not copy with alt + w when copying enemies?

UE4.27
This is so annoying. Can someone help? Should I make my own thread???

My character (3D SideScroller) is pushing my AI off ledges, just by me running back and forth past the AI. The AI flies off like it was hit with a 10000 force, and goes airborn. I do not want this.

Sometimes when I run/move past my AI (and we are in the same plane), the AI gets NUDGED to the side - which is fine (I want this). But I do not want the 10000 push and the AI gets vertical air.

What is causing this? That is what is annoying me, that Idk.

I tried:

    • Player BP > Character Movement comp > Mass set to 1 (AI mass set to 10000 - yet still my 1 mass Player pushes the heavy AI into the air???)
    • Player BP > Character Movement comp > “Depenetration” = tried setting all to 0. Didnt help.
    • Player BP > Character Movement comp > [Character Movement: Physics Interaction] > set Enable Physics Interaction = False (on both Player and AI). But still I push AI into the air by running by him.
    • Idk if its Touch force or Push Force, etc. But I toggled off Enable Physics Interaction, and the other settings go gray, so they should be off.
    • Player BP > Capsule Comp > Collision Enabled = Query and Physics (I need this).
    • Player BP > Mesh (Character) > Collision Presets = Custom (I need some block channels to be on. I have some physics bones that I forgot how I setup or which channels need to be on, if any. I just remember if I turned Coll off, I fall thru the ground, or some of my physics bones dont work.)

      Please help, thank you.