AI character not moving to either target or myself


Ive just watched Ian Shaddens video on youtube about the basics of AI. I have followed every step in the third person template like he did and it worked. However, when i try this in my own project which is a first person template the AI is just standing there looping the animation. Not moving to either target points or myself if I change the “AI goal”

I have also tried copying the third person template and blueprint into my own project to see if i could make a AI character from the third person character.

Hope this makes any sense and I would be really greatful for any tips or ideas :slight_smile:

Would you mind just posting a project that exhibits these issues? Having a repro-project always helps! :smiley:



This is a wild guess, but I’m guessing you don’t have navmesh :smiley: AI needs navmesh to move properly. Can you confirm you have navigation set up properly (you need at least a NavMeshBoundsVolume on your map)?



This is the AI controller I made. This is selected in the character AI. Did this exact same setup in the third person template and it works there. The only difference is that the AI in the third person template is a duplicate of the “player” character.

Yup, the navmesh is set up and displays properly. It kinda “floats” a little above ground tho if thats got anything to do with it

I need your project then. Nothing seems out of ordinary at first glance.

You said you’ve started with First Person template, followed the tutorial and it worked. It shouldn’t be too big, and there’s a lot you can cut still (like all the materials, textures, all static meshes unused in your map, etc).

You basically just need the Content, Config and Sources (if you have one) directories, plus the uproject file. And there’s also a fair amount of stuff to cut from the Content folder if you’re don’t care about the visuals (and we don’t in this case).

Like the whole game? Or just the project file? The whole package with content is kinda big.

The tutorial was done in the third person template, so i tried it in a new third person template and that did work. However when im trying to do it in my own project, which is first person it dont work. The whole project size for my own project is 9gb cause you know “really good” at UE :smiley:

But i can try do reduce it later and upload it :slight_smile:

Okay. Will try to upload it later today. Just tried doing it again in a new first person template. Just created a new AI and controller and it works there aswell. It just dont work in my own project. So something is wrong within that.

I take it it’s zipped, right? It’s fine. I suggest putting it in dropbox or google drive and sending me a link to

Got the project down to 600mb. Is that too big or? :slight_smile:
If its good, should i post the download link here on send it to you somewhere else?

Yepp, zipped with winrar. Okay, uploading now. But my up-connection is pretty slow so it might take a few hours. I will send you the link as soon it`s done :slight_smile:

I have sent you an email now MieszkoZ :slight_smile:

Figured it out. Had no idea that the navmesh bounds had be built in the persistent level and not any of the sublevels :slight_smile:

Yeah, sorry for not responding, I was at Digital Dragons. Currently you need NavMeshBounds in the persistent level, but we’re going to make it so that you can put the bounds just anywhere (sometime this year hopefully).