AI character is not using Movement Input Vector

So I have a Frog blueprint, inheriting from Character.

I’m overriding the movement logic to make it hop along rather than normal character movement.

Basically, in my Tick event, I use “Consume Movement Input Vector” to intercept the movement input and then use it to either hop forward (using Launch Character) or enter a rotation state to rotate over time until we’re facing the desired input direction.

If I possess a Frog as the player, this all works perfectly.

Now, I have set up an AI Controller, Blackboard and Behavior Tree and am trying to get the AI Frog working. First, I set a blackboard value to the player.

If I use the task “Move To”, the Frog does indeed move to the player… but it just slides at the player, ignoring all the custom movement logic. I had assumed “Move To” would achieve it’s movement under the hood with Add Movement Input so that the AI can control the character in a similar way a player would. Apparently it completely overrides the way a character moves; that sucks.

So, I tried creating my own custom BT Task. In it, I get the owning AI Controller’s Pawn and then Add Movement Input towards the player, grabbed from the Blackboard. The Frog still slides towards the player, however it slides extremely slowly.

If I try to ‘Print’ the value of the input vector in the Frog to debug it, it’s always 0… despite that it’s moving.

I’m flabbergasted. Any ideas?

Have you tried forcing it to consume the movement component input. It normally does that anyway but it may be failing for some reason.

makes no difference