Download

AI can't move if I spawn too many

I’m using Unreal Engine 4.14.3 from source code on github. I’m making a multiplayer game. When I spawn about 60 - 80 enemy pawns (in different location), some of enemies can’t move… I check all NavMesh and it is okay, active pawn can move to area that disable pawn can’t. When debug, the result of “AI Move To” is abort …
I tried a lot of suggestions with google but it’s not work…

  • Check Collision - There is no collision on that area.

  • Check NavMesh - It’s pretty okay, some enemy can walk on area that disable one can’t.

  • Try to use “Simple Move To Actor”, “Simple Move To Location”, …

  • Try to reduce enemy pawn, it’s work…

I’m not sure is it a bug or not. Do you guys have any suggestion?

*Ps. Sorry about my english. I know it’s not good.

I have the same problem too.
Anyone can help us, please?

Super late reply, but might help someone though.
By default Crowd manager Max Agents limit is set to 50, so any AI over the 50 limit will not be able to move.
To change this increase the number at: Project Settings->Crowd Manager->Max Agents

1 Like

So simple, had me over 2 days trying to work this out, thank you!