After using retopologize, significant lag while painting

After using retopologize on even a small part of a landscape component, there is significant lag while using the paintbrush anywhere on that component, either for painting layers, or sculpting. (I have not tried foliage)

The lag happens after left click is released. This makes detail painting especially painful since a lot of clicking is involved.

Is there any way to remove what has been done with the retopologize tool?

Hi InternetPotatoMan,

I haven’t been able to reproduce this on my end. If you open your console commands and type stat fps, what is the drop that you are seeing while working with the paint tool after retopologizing?

Well, since the hotfix I am no longer able to reproduce this… Before the hotfix it happened every time… Oh well!

Anyway. When it happened stat fps didnt show an actual drop… the entire editor stopped for about a second

Hi InternetPotatoMan,

I’m happy to hear this is no longer occurring for you. I am going to mark this as answered for tracking purposes. If this occurs again, please comment and let me know what specific steps you took just before this occurred.

Hey Adam, I am having a similar problem. How can I fix this, and if not how can I “erase” retopology?

Try using the smooth tool over the retopologized area to alter the vertices affected. Does this help?

Hello there! I’m having this same issue in unreal version 4.12.5. I didn’t find a solution yet and I tried using the smooth tool over the retopologized areas :frowning: . Any ideas on ho wto solve this?

HI VGuerreiro,

I was able to reproduce this on my end and have entered a bug report, UE-33387, to be assessed by the development staff.

So i have been sculpting my terrain this entire day and decided to do a little bit of retopology but this exact issue now occurs to me, i tried smoothing over the area but it still freezes for 5 seconds or so after each stroke, no matter which sculpting tool is used.

type this into the console: RemoveLandscapeXYOffsets

Shout out to the person who found this :slight_smile:

(this is an old thread but it’s no1 on google when you type it in etc etc)