after latest launcher update today I can't download engine versions *SOLVED*

I have never had this problem before. The Launcher wanted to update today, so I let it reboot. Now I can’t click the plus sign next to Engine Versions, as if it were greyed out. I want to add an older engine, and this always worked before.

Is it possible that you already have an uninstalled version selected like this?

My screen looks like this:

The plus sign is unclickable. I used to be able to simply click this. I have projects in 4.15, so I need to re-install 4.15. Something in them won’t work right with the current version.

The reason the plus sign is unclickable is because you already have a pending installation for version 4.21.0, preview 4. Click on the dropdown arrow next to 4.21.0 and you will be able to change the selected version you would like to install. And then click the install button.

Thanks! That worked just as you said. It was just not obvious to me.

Awesome to hear your problem is fixed! Do you mind marking my answer as correct so that this is no longer an unanswered question?