After installing a new GPU, Unreal Engine interface is blurry

Hello, and sorry if it’s the wrong section to post this

I just installed a new GPU, I used DDU to clean old drivers beforehand. Since then my unreal interface has been blurry.

Here is a comparison from another user in the discord

top is my shot, bottom is a discord user comparing it with theirs

he says “I would almost say like it was 720p being rendered at a higher resolution”, I’ve ensured that anything like DSR in nvidia control panel is off just in case

My resolution has been the same (1920x1080) as it was before installing.

I’ve tried:

reinstalling the engine

deleting intermediate and saved folders (as recommended in forums)

toggled the high DPI settings under editor settings

tried toggling windows 10 scaling for apps under advanced scaling settings

under compatibility settings for ueeditor (C:\Program Files\Epic Games\UE_4.24\Engine\Binaries\Win64\UEEditor.exe), made sure all scaling options are disabled, such as, disable fullscreen optimizations, and disable everything under high DPI settings

configuring various options for the editor under nvidias control panel

i’ve also tried running with the argument -enablehighdpi as suggested in forums,

this is after a new GPU install, I used DDU to clean old drivers beforehand, I’m not sure what else to try

Since this issue, I have re-installed my graphics drivers twice, I was having frequent crashes because unreal would lose sync to d3d to my understanding, when I re-installed the drivers a second time (through nvidia gforce experience instead of ddu this time) the blurriness and crashes no longer occur.

Having blurriness and d3d crashes? Re-install your drivers clean using Nvidia’s or AMD’s official software, try it multiple times.