After importing my animations from Blender to UE4, there is a strange twitching in the feet of one of my animations

I recently imported a few animations from Blender to UE4 to make sure they would work fine in UE4, and for the most part they did. There is one strange issue, though, which makes me nervous to continue animating because I’m not sure how significant it could be in the future.

In my 1 second animation, there’s a point in the middle where each of the feet sort of twitch to left a bit. This only happens in the idle animation, and nothing similar happens in any of the other 12 animations I ported over.

For reference, here is what it looks like in Blender:

Here is what it looks like in UE4:

The issue goes away (mostly) when I delete the hip bone (the hips sway left and right a bit as my model shifts his weight from front to back), but it’s very confusing why the feet only have this problem for such a short period of time. The hips are swaying the entire animation, but this issue only appears briefly in the middle of the animation.

There aren’t any keyframes on the feet, other than one foot roll bone which bounces the heel up and down. I’ve also tried adding keyframes around that point in time to lock in the position, but it does absolutely nothing.

Just…completely confused why the animation wouldn’t match up 1 to 1 from Blender to UE4.

The solution to this problem would be to check “Preserve local transforms” in your animation import options. You can also reimport your animations with those options.

1 Like

I had a similar issue. The animation looked solid in Blender, but feet sometimes shifted slightly in UE4. It was caused by the FBX export. Setting “Simplify” to 0 in the Animation category of the FBX export options solved the problem for me. You could also try changing the “Sampling Rate”.

Thank you!!!

Thank you my brother. Any explanation as to why this solution works? Any reason to not ever have this option checked?