After downloading the 4.15 source from GitHub, error at GenerateProjectFiles.bat

I’m following a tutorial on building a dedicated server.

After downloading the .zip 4.15 project version from GitHub, I ran the Setup.bat and then GenerateProjectFiles.bat.

I’m stuck at GenerateProjectFiles.bat, giving me these errors:

Setting up Unreal Engine 4 project files...
Messages while compiling D:\UnrealEngine-4.15\Engine\Intermediate\Build\BuildRules\UE4Rules.dll:
d:\UnrealEngine-4.15\Engine\Source\ThirdParty\NVIDIA\NVaftermath\NVaftermath.Build.cs(7,11) : error CS1729: 'UnrealBuildTool.ModuleRules' does not contain a constructor that takes 1 arguments
d:\UnrealEngine-4.15\Engine\Source\ThirdParty\NVIDIA\NVaftermath\NVaftermath.Build.cs(11,14) : error CS1061: 'UnrealBuildTool.ReadOnlyTargetRules' does not contain a definition for 'Platform' and no extension method 'Platform' accepting a first argument of type 'UnrealBuildTool.ReadOnlyTargetRules' could be found (are you missing a using directive or an assembly reference?)
UnrealBuildTool Exception: ERROR: UnrealBuildTool encountered an error while compiling source files

GenerateProjectFiles ERROR: UnrealBuildTool was unable to generate project files.

Press any key to continue . . .

I tried downloading, extracting and running Setup.bat and GenerateProjectFiles.bat several times but it always gives me this same error.

Any thoughts? Thanks.

I incorrectly downloaded the branch 4.15 version from GitHub. The correct one is the one tagged with 4.15.1-release. Sorry!